Настройка маршрутизатора HP/H3C A-MSR900 JF812A

Профессиональным сетевым администраторам эта заметка покажется бесполезной, т.к. в ней описываются совершенно базовые вещи. Моя профессия связана с Linux-серверами, а не компьютерными сетями, но для общего развития я иногда пытаюсь изучать смежные области. В этой заметке собраны команды, которые могут пригодиться мне самому.

Интерфейс командной строки маршрутизатора НЕ похож на таковой у маршрутизаторов Cisco, а практически совпадает, за редкими небольшими исключениями, с интерфейсом командной строки коммутаторов Huawei. Для входа в режим администратора используется команда system-view, а для возврата обратно в режим пользователя - команда return. Команда quit позволяет выйти из текущего режима или отключиться от устройства, если текущий режим - режим пользователя. Вместо привычной для оборудования Cisco команды show используется команда display, которая обычно доступна во всех режимах.

Посмотреть текущую конфигурацию маршрутизатора можно при помощи команды display this, причём если вы находитесь в каком-то специфичном режиме настройки, то будет отображена только та часть конфигурации, которая имеет отношение к текущему режиму. Например в режиме настройки интерфейса будет показана конфигурация настраиваемого интерфейса.

Подключение к маршрутизатору

Для подключения к консоли маршрутизатора я воспользовался кабелем для COM-порта, идущим в комплекте с маршрутизатором, и программой minicom.

Для изменения настроек minicom, используемых по умолчанию, можно воспользоваться такой командой:

# minicom -s

По умолчанию COM-порт маршрутизатора настроен так:

  • Скорость обмена данными - 9600 бод
  • Контроль чётности - отсутствует
  • Битов данных - 8
  • Стоп-битов - 1

После явного ручного указания всех этих настроек у меня получился такой файл /etc/minicom/minirc.dfl:

# Автоматически сгенерированный файл - используйте "minicom -s" для
# изменения параметров.
pu port             /dev/ttyUSB0
pu baudrate         9600
pu bits             8
pu parity           N
pu stopbits         1

Теперь для подключения к консоли осталось просто запустить команду:

# minicom

Выйти из minicom можно по нажатию следующих клавиш:

Ctrl+A Z Q

FIXME: По умолчанию на маршрутизаторе настроен пользователь admin с паролем admin.

FIXME: Первоначальную настройку маршрутизатора можно производить и по сети. По умолчанию на нём настроен IP-адрес 192.168.1.1 с маской 255.255.255.0 и включен telnet.

Просмотр информации о маршрутизаторе

Просмотр модели маршрутизатора, объёмов оперативной и флэш-памяти, версий установленного на нём программного обеспечения:

<HP>display version 
HP Comware Platform Software
Comware Software, Version 5.20, Release 2209L22, RU
Copyright (c) 2010-2012 Hewlett-Packard Development Company, L.P.
HP A-MSR900 uptime is 0 week, 0 day, 0 hour, 1 minute
Last reboot 2007/01/01 00:00:29
System returned to ROM By Power-up.

CPU type: FREESCALE MPC8313 266MHz
256M bytes DDR2 SDRAM Memory
256M bytes Flash Memory
Pcb               Version:  3.0
Logic             Version:  1.0
Basic    BootROM  Version:  1.16
Extended BootROM  Version:  1.16
[SLOT  0]AUX            (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]ETH0/0         (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]ETH0/1         (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]ETH0/2         (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]ETH0/3         (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]ETH0/4         (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]ETH0/5         (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0
[SLOT  0]CELLULAR0/0    (Hardware)3.0,  (Driver)1.0,    (Cpld)1.0

Просмотр модели маршрутизатора, состояния и максимального количества портов (физически их всего 6):

<HP>display device
 Slot No.  Board Type                Status    Max Ports
 0         A-MSR900 RPU Board        Normal       8

Просмотр серийного номера и MAC-адреса:

<HP>display device manuinfo 
slot 0
DEVICE_NAME          : A-MSR 900 JF812A
DEVICE_SERIAL_NUMBER : XXXXXXXXXX
MAC_ADDRESS          : 7848-59XX-XXXX
MANUFACTURING_DATE   : 2015-01-11
VENDOR_NAME          : HP

Просмотр состояния слота 0:

display device slot 0 Slot 0 Status: Normal Type: A-MSR900 RPU Board Hardware: 3.0 Driver: 1.0 CPLD: 1.0

Управление файлами

На маршрутизаторе имеется встроенная флеш-память, на которой хранятся различные файлы, в том числе с прошивкой маршрутизатора. Посмотреть список файлов можно при помощи команды dir:

<HP>dir               
Directory of flash:/

   0     -rw-  20679804  Jan 01 2007 00:03:28   a_msr9xx-cmw520-r2209l22-ru.bin
   1     drw-         -  Jan 01 2007 00:00:15   domain1
   2     drw-         -  Jan 01 2007 00:00:02   logfile
   3     -rw-     16256  Jan 01 2007 00:01:26   p2p_default.mtd
   4     -rw-      3539  Jan 01 2007 00:06:19   system.xml
   5     -rw-      1243  Jan 01 2007 00:06:21   startup.cfg

261760 KB total (240232 KB free)

Можно заметить, что некоторые строчки помечены атрибутом d. Это каталоги. Переходить в них и обратно в родительский каталог можно при помощи команды cd:

<HP>cd logfile
<HP>cd ..

Каталоги можно создавать и удалять при помощи команд mkdir и rmdir:

<HP>cd testdir
% Such file or path doesn't exist. 

<HP>mkdir testdir

%Created dir flash:/testdir.

<HP>cd testdir
<HP>cd ..
<HP>rmdir testdir
Rmdir flash:/testdir?[Y/N]:Y

%Removed directory flash:/testdir.

Файлы можно копировать, перемещать, переименовывать и удалять при помощи команд copy, move, rename и delete соответственно:

<HP>copy startup.cfg startup.bak
Copy flash:/startup.cfg to flash:/startup.bak?[Y/N]:Y
.
%Copy file flash:/startup.cfg to flash:/startup.bak...Done.
<HP>move startup.bak startup.new
Move flash:/startup.bak to flash:/startup.new?[Y/N]:Y

%Moved file flash:/startup.bak to flash:/startup.new.
<HP>rename startup.new startup.bak
Rename flash:/startup.new to flash:/startup.bak?[Y/N]:Y

%Renamed file flash:/startup.new to flash:/startup.bak.
<HP>delete startup.bak

Delete flash:/startup.bak?[Y/N]:Y

%Delete file flash:/startup.bak...Done.

Сохранить текущую конфигурацию в текстовый файл можно следующим образом:

<HP>save
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):
flash:/startup.cfg exists, overwrite? [Y/N]:y
 Validating file. Please wait....
 Configuration is saved to device successfully.

Посмотреть содержимое файла можно при помощи команды more:

<HP>more startup.cfg

Посмотреть конфигурацию, которая будет применена при загрузке маршрутизатора, можно при помощи такой команды:

<HP>display saved-configuration

Управление конфигурацией и прошивками маршрутизатора

<HP>display startup 
 Current startup saved-configuration file: flash:/startup.cfg
 Next main startup saved-configuration file: flash:/startup.cfg
 Next backup startup saved-configuration file: NULL

Настройка начальных сведений о маршрутизаторе

Входим в режим настройки маршрутизатора:

<HP>system-view
Enter system view, return user view with Ctrl+Z.

Настраиваем имя маршрутизатора:

[HP]sysname hp

Вернуться из режима настройки в пользовательский режим можно при помощи команды return:

[hp]return
<hp>

Настройка контактов системного администратора и местоположения маршрутизатора производится через команды настройки агента SNMP:

[hp]snmp-agent sys-info contact vladimir@stupin.su
[hp]snmp-agent sys-info location Ufa

Увидеть настроенные данные можно следующим образом:

display snmp-agent sys-info The contact person for this managed node: vladimir@stupin.su

The physical location of this node: Ufa

SNMP version running in the system: SNMPv3

Настройка пользователей и паролей

Настройка пользователей маршрутизатора происходит в режиме system-view:

 <hp>system-view
[hp]

Переходим к настройке локального пользователя с логином stupin:

[hp]local-user stupin 
New local user added.
[hp-luser-stupin]

Как видно, на маршрутизаторе не было пользователя с указанным логином и он был создан, после чего маршрутизатор перешёл в режим настройки нового пользователя.

Настраиваем локального пользователя с паролем, которому разрешаем заходить по SSH и назначаем наивысшие привилегии:

[hp-luser-stupin]password cipher $ecretP4ssw0rd
[hp-luser-stupin]service-type ssh 
[hp-luser-stupin]authorization-attribute level 3

Выйти из режима настройки локального пользователя можно при помощи команды quit. Возврат в начальный режим, как обычно, происходит по команде return:

[hp-luser-stupin]quit
[hp]return
<hp>

Но из режима настройки пользователя не обязательно выходить по команде quit, если вы хотите вернуться сразу в начальный режим. Вернуться в него можно напрямую - по команде return.

Посмотреть список настроенных локальных пользователей можно следующим образом:

<hp>display local-user 
The contents of local user admin:
 State:                    Active
 ServiceType:              telnet/web
 Access-limit:             Disabled          Current AccessNum: 0
 User-group:               system
 Bind attributes:
 Authorization attributes:
  User Privilege:          3
The contents of local user stupin:
 State:                    Active
 ServiceType:              ssh
 Access-limit:             Disabled          Current AccessNum: 0
 User-group:               system
 Bind attributes:
 Authorization attributes:
  User Privilege:          3
Total 2 local user(s) matched.

Для удаления локального пользователя можно воспользоваться командой undo local-user с именем удаляемого пользователя:

<hp>system-view 
System View: return to User View with Ctrl+Z.
[hp]undo local-user admin
[hp]return
<hp>

Маршрутизатор позволяет удалить пользователя, даже если он используется в текущем сеансе.

Просмотр состояния портов и VLAN

Посмотреть текущее состояние портов можно при помощи команды display interface brief:

<hp>display interface brief 
The brief information of interface(s) under route mode:
Link: ADM - administratively down; Stby - standby
Protocol: (s) - spoofing
Interface            Link Protocol Main IP         Description
Aux0                 UP   UP       --
Cellular0/0          DOWN DOWN     --
Eth0/0               DOWN DOWN     10.0.0.1
Eth0/1               DOWN DOWN     --
NULL0                UP   UP(s)    --
Vlan1                DOWN DOWN     192.168.1.1

The brief information of interface(s) under bridge mode:
Link: ADM - administratively down; Stby - standby
Speed or Duplex: (a)/A - auto; H - half; F - full
Type: A - access; T - trunk; H - hybrid
Interface            Link Speed   Duplex Type PVID Description
Eth0/2               DOWN auto    A      A    1
Eth0/3               DOWN auto    A      A    1
Eth0/4               DOWN auto    A      A    1
Eth0/5               DOWN auto    A      A    1

Как видно, сначала выводятся порты, находящиеся в режиме маршрутизации, а потом - в режиме коммутации.

Посмотреть список портов и VLAN на них можно при помощи команд display vlan all:

[hp]display vlan all 
 VLAN ID: 1
 VLAN Type: static
 Route Interface: configured
 IP Address: 192.168.1.1
 Subnet Mask: 255.255.255.0
 Description: VLAN 0001
 Name: VLAN 0001
 Tagged   Ports: none
 Untagged Ports:
    Ethernet0/2              Ethernet0/3              Ethernet0/4
    Ethernet0/5

Настройка портов и VLAN

Переходим в режим настройки маршрутизатора:

<hp>system-view 
Enter system view, return user view with Ctrl+Z.

Вход в режим настройки порта (выход осуществляется по команде quit):

[hp]interface Ethernet 0/2
[hp-Ethernet0/2]

В режиме настройки интерфейса можно задать его описание:

[hp]interface Ethernet 0/2
[hp-Ethernet0/2]description mgmt
[hp-Ethernet0/2]quit

Очистить описание у интерфейса можно следующим образом:

[hp]interface Ethernet 0/2
[hp-Ethernet0/2]undo description
[hp-Ethernet0/2]quit

Для переключения режима работы порта из коммутируемого в маршрутизируемый можно воспользоваться командой port link-mode route:

[hp-Ethernet0/2]port link-mode route

Для обратного переключения режима работы порта из маршрутизируемого в коммутируемый можно воспользоваться командой port link-mode bridge:

[hp-Ethernet0/2]port link-mode bridge

Стоит учитывать, что первые два порта Ethernet 0/0 и Ethernet 0/1 работают только в маршрутизируемом режиме, а попытка поменять их режим работы на коммутируемый завершится выводом сообщения об ошибке следующего вида:

 Error: This mode is not supported on this interface!

Перед настройкой VLAN на портах маршрутизатора можно настроить описание каждой VLAN:

[hp]vlan 1
[hp-vlan1]name default
[hp-vlan1]vlan 2
[hp-vlan2]name System
[hp-vlan2]quit
[hp]

Настроить VLAN в режиме доступа на порту можно и так:

[hp]interface Ethernet 0/2
[hp-Ethernet0/2]port access vlan 2
[hp-Ethernet0/2]

По умолчанию все коммутируемые порты маршрутизатора настроены в режиме доступа в VLAN 1 - принимают Ethernet-кадры без меток и помечают их как принадлежащие VLAN 1.

Переключить порт коммутатора в режим транк можно следующим образом:

[hp]interface Ethernet 0/2
[hp-Ethernet0/2]port link-type trunk
[hp-Ethernet0/2]

Определить список VLAN на транк-порту можно следующим образом:

[hp-Ethernet0/2]port trunk permit vlan 2
 Please wait... Done.

Можно указать номера нескольких VLAN через пробел. Вместо одного номера можно указать диапазон, разделив начальный и конечный номера ключевым словом to:

[hp-Ethernet0/2]port trunk permit vlan 1 to 4 8 

Если на интерфейс поступит пакет без метки, то его можно принять как принадлежащую VLAN по умолчанию для этого порта. Для указания номера VLAN по умолчанию для этого порта можно воспользоваться командой такого вида:

[hp-Ethernet0/2]port trunk pvid vlan 2

Кроме режима транк можно настроить коммутируемый порт в гибридном режиме, воспользовавшись ключевым словом hybrid:

[hp-Ethernet0/2]port link-type hybrid

Переключить порт в гибридный или транк-режимы можно только из режима доступа. Если порт находится в другом режиме, то будет выведено сообщение об ошибке:

 Because it is a Trunk-port, Hybrid can not be specified, please set it Access first.

Для переключения порта в режим доступа можно воспользоваться такой командой:

[hp-Ethernet0/2]port link-type access
 Please wait........................................... Done.

В гибридном режиме VLAN по умолчанию для входящих пакетов можно настроить следующим образом:

[hp-Ethernet0/2]port hybrid pvid vlan 2

Следующим образом можно разрешить пакетам из VLAN 2 покидать порт в нетегированном режиме:

[hp-Ethernet0/2]port hybrid vlan 2 untagged
 Please wait... Done.

Наконец, вот так можно разрешить движение через порт тегированных пакетов, принадлежащих VLAN 1:

[hp-Ethernet0/2]port hybrid vlan 1 tagged
 Please wait... Done.

Настройка IP-адреса и шлюза

По умолчанию на маршрутизаторе настроен интерфейс в VLAN 1 с IP-адресом 192.168.1.1 и маской сети 255.255.255.0:

<hp>display interface Vlan-interface 1
Vlan-interface1 current state: DOWN
Line protocol current state: DOWN
Description: Vlan-interface1 Interface
The Maximum Transmit Unit is 1500
Internet Address is 192.168.1.1/24 Primary
IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 7848-59da-b569
IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 7848-59da-b569
 Last clearing of counters:  Never
    Last 300 seconds input rate: 0 bytes/sec, 0 bits/sec, 0 packets/sec
    Last 300 seconds output rate: 0 bytes/sec, 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 drops
    0 packets output, 0 bytes, 0 drops

Настроим новый интерфейс в VLAN 2. Для этого сначала перейдём в режим настройки:

<hp>system-view                                                                 
System View: return to User View with Ctrl+Z. 

Настраиваем IP-адрес и маску на интерфейсе.

[hp]interface Vlan-interface 2
[hp-Vlan-interface2]ip address 192.168.254.29 24

Для удаления IP-адреса с интерфейса можно воспользоваться командой undo:

[hp-Vlan-interface2]undo ip address 192.168.254.29 24

Добавим описание к интерфейсу:

[hp-Vlan-interface2]description Uplink, snr.lo.ufanet.ru, port 1

Выходим из режима настройки интерфейса:

[hp-Vlan-interface2]quit

Использованные материалы